7.4.1 Packet Tracer – Implement DHCPv4 (Instructor Version)
Addressing Table
Device | Interface | IPv4 Address | Subnet Mask | Default Gateway |
---|---|---|---|---|
R1 | G0/0 | 192.168.10.1 | 255.255.255.0 | N/A |
S0/0/0 | 10.1.1.1 | 255.255.255.252 | ||
R2 | G0/0 | 192.168.20.1 | 255.255.255.0 | N/A |
G0/1 | DHCP Assigned | DHCP Assigned | ||
S0/0/0 | 10.1.1.2 | 255.255.255.252 | ||
S0/0/1 | 10.2.2.2 | 255.255.255.252 | ||
R3 | G0/0 | 192.168.30.1 | 255.255.255.0 | N/A |
S0/0/1 | 10.2.2.1 | 255.255.255.0 | ||
PC1 | NIC | DHCP Assigned | DHCP Assigned | DHCP Assigned |
PC2 | NIC | DHCP Assigned | DHCP Assigned | DHCP Assigned |
DNS Server | NIC | 192.168.20.254 | 255.255.255.0 | 192.168.20.1 |
Objectives
- Part 1: Configure a Router as a DHCP Server
- Part 2: Configure DHCP Relay
- Part 3: Configure a Router as a DHCP Client
Scenario
As the network technician for your company, you are tasked with configuring a Cisco router as a DHCP server to provide dynamic allocation of addresses to clients on the network. You are also required to configure the edge router as a DHCP client so that it receives an IP address from the ISP network. Since the server is centralized, you will need to configure the two LAN routers to relay DHCP traffic between the LANs and the router that is serving as the DHCP server.
Instructions
Part 1: Configure a Router as a DHCP Server
Step 1: Configure the excluded IPv4 addresses.
Configure R2 to exclude the first 10 addresses from the R1 and R3 LANs. All other addresses should be available in the DHCP address pool.
R2(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.10
R2(config)#ip dhcp excluded-address 192.168.30.1 192.168.30.10
Step 2: Create a DHCP pool on R2 for the R1 LAN.
a. Create a DHCP pool named R1-LAN. The pool name must match this value in order for you to get credit for your configuration.
b. Configure the DHCP pool to include the network address, the default gateway, and the IP address of the DNS server.
R2(config)#ip dhcp pool R1-LAN
R2(dhcp-config)#network 192.168.10.0 255.255.255.0
R2(dhcp-config)#default-router 192.168.10.1
R2(dhcp-config)#dns-server 192.168.20.254
Step 3: Create a DHCP pool on R2 for the R3 LAN.
a. Create a DHCP pool named R3-LAN (case-sensitive).
b. Configure the DHCP pool to include the network address, the default gateway, and the IP address of the DNS server.
R2(config)#ip dhcp pool R3-LAN
R2(dhcp-config)#network 192.168.30.0 255.255.255.0
R2(dhcp-config)#default-router 192.168.30.1
R2(dhcp-config)#dns-server 192.168.20.254
Part 2: Configure DHCP Relay
Step 1: Configure R1 and R3 as a DHCP relay agent.
R1(config)#interface g0/0
R1(config-if)#ip helper-address 10.1.1.2
R3(config)#interface g0/0
R3(config-if)#ip helper-address 10.2.2.2
Step 2: Set PC1 and PC2 to receive IP addressing information from DHCP.
Part 3: Configure R2 as a DHCP Client
Step 1: Configure the Gigabit Ethernet 0/1 interface on R2 to receive IP addressing from DHCP.
Step 2: Activate the interface.
R2(config)#interface g0/1
R2(config-if)#ip address dhcp
R2(config-if)#no shutdown
Answer Scripts
Router R1
enable conf t interface GigabitEthernet0/0 ip helper-address 10.1.1.2 end
Router R2
enable conf t ip dhcp excluded-address 192.168.10.1 192.168.10.10 ip dhcp excluded-address 192.168.30.1 192.168.30.10 ip dhcp pool R1-LAN network 192.168.10.0 255.255.255.0 default-router 192.168.10.1 dns-server 192.168.20.254 ip dhcp pool R3-LAN network 192.168.30.0 255.255.255.0 default-router 192.168.30.1 dns-server 192.168.20.254 interface GigabitEthernet0/1 ip address dhcp no shutdown end
Router R3
enable conf t interface GigabitEthernet0/0 ip helper-address 10.2.2.2 end
Download PDF & PKA file:
[sociallocker id=”54558″]
[wpdm_package id=’39095′]
[wpdm_package id=’39094′]
[/sociallocker]
[alert-note][one_half]
Previous Lab
7.2.10 Packet Tracer – Configure DHCPv4
[/one_half][one_half_last]
Next Lab
9.3.3 Packet Tracer – HSRP Configuration Guide
[/one_half_last][/alert-note]