10.6.11 Lab – Use Tera Term to Manage Router Configuration Files (Answers)

Lab – Use Tera Term to Manage Router Configuration Files (Instructor Version)

Topology

Addressing Table

Device Interface IP Address Subnet Mask Default Gateway
R1 G0/0/1 192.168.1.1 255.255.255.0 N/A
S1 VLAN 1 192.168.1.11 255.255.255.0 192.168.1.1
PC-A NIC 192.168.1.3 255.255.255.0 192.168.1.1

Objectives

  • Part 1: Configure Basic Device Settings
  • Part 2: Use Terminal Emulation Software to Create a Backup Configuration File
  • Part 3: Use a Backup Configuration File to Restore a Router and Switch Configuration

Background / Scenario

It is a recommended best practice to maintain backup configuration files for routers and switches in the event that they need to be restored to a previous configuration. Terminal emulation software can be used to easily back up or restore a router or switch configuration file.

In this lab, you will:

  • Use Tera Term to back up a router running-configuration file.
  • Erase the router startup configuration file.
  • Reload the router.
  • Restore the missing router configuration from the backup configuration file.

Note: The routers used with CCNA hands-on labs are Cisco 4221 with Cisco IOS XE Release 16.9.4 (universalk9 image). The switches used in the labs are Cisco Catalyst 2960s with Cisco IOS Release 15.2(2) (lanbasek9 image). Other routers, switches, and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and the output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of the lab for the correct interface identifiers.

Note: Ensure that the routers and switches have been erased and have no startup configurations. If you are unsure contact your instructor.

Instructor Note: Refer to the Instructor Lab Manual for the procedures to initialize and reload devices

Instructor Note: This lab uses Tera Term 4.103. Tera Term should be installed on the PC prior to starting the lab. You can download the latest version from a number of Internet sites. Simply search for a Tera Term download.

Required Resources

  • 1 Router (Cisco 4221 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 1 Switch (Cisco 2960 with Cisco IOS Release 15.2(2) lanbasek9 image or comparable)
  • 1 PC (Windows with a terminal emulation program, such as Tera Term)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet cables as shown in the topology Ethernet cables as shown in the topology

Part 1: Configure Basic Device Settings

In Part 1, you will set up the network topology and configure basic settings, such as the interface IP addresses, device access, and passwords on the router.

Step 1: Cable the network as shown in the topology.

Attach the devices as shown in the topology and cable as necessary.

Step 2: Configure the PC-A network settings according to the Addressing Table.
Step 3: Configure basic settings for the router.

a. Assign a device name to the router.

router(config)# hostname R1

b. Disable DNS lookup to prevent the router from attempting to translate incorrectly entered commands as though they were host names.

R1(config)# no ip domain lookup

c. Assign class as the privileged EXEC encrypted password.

R1(config)# enable secret class

d. Assign cisco as the console password and enable login.

R1(config)# line console 0
R1(config-line)# password cisco
R1(config-line)# login

e. Assign cisco as the VTY password and enable login.

R1(config)# line vty 0 4
R1(config-line)# password cisco
R1(config-line)# login

f. Encrypt the plaintext passwords.

R1(config)# service password-encryption

g. Create a banner that warns anyone accessing the device that unauthorized access is prohibited.

R1(config)# banner motd $ Authorized Users Only! $

h. Configure interfaces as listed in the table above.

R1(config-if)# interface g0/0/1
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# end

i. Save the running configuration to the startup configuration file.

R1# copy running-config startup-config
Step 4: Configure basic settings for the switch.

a. Assign a device name to the switch.

switch(config)# hostname S1

b. Disable DNS lookup to prevent the router from attempting to translate incorrectly entered commands as though they were host names.

S1(config)# no ip domain-lookup

c. Assign class as the privileged EXEC encrypted password.

S1(config)# enable secret class

d. Assign cisco as the console password and enable login.

S1(config)# line console 0
S1(config-line)# password cisco
S1(config-line)# login

e. Assign cisco as the VTY password and enable login.

S1(config)# line vty 0 15
S1(config-line)# password cisco
S1(config-line)# login

f. Encrypt the plaintext passwords.

S1(config)# service password-encryption

g. Create a banner that warns anyone accessing the device that unauthorized access is prohibited.

S1(config)# banner motd $ Authorized Users Only! $

h. Shut down all unused interfaces

S1(config)# interface range f0/1-4, f0/7-24, g0/1-2
S1(config-if-range)# shutdown
S1(config-if-range)# end

i. Configure interface VLAN 1 as specified in the table above.

S1(config)# interface vlan 1
S1(config-if)# ip address 192.168.1.11 255.255.255.0
S1(config-if)# no shutdown
S1(config-if)# exit
S1(config)# ip default-gateway 192.168.1.1

j. Save the running configuration to the startup configuration file.

S1(config)# exit
S1# copy running-config startup-config

Part 2: Create a Backup Configuration File

In Tera Term or other terminal emulation program, you can create a log of your commands and output to a device via a connection. In this part, you will record your interaction with a device using the logging feature of Tera Term.

Note: If Tera Term is not installed, you can download the latest version from a number of internet sites. Simply search for a Tera Term download.

Step 1: Create a log file.

a. Connect to the router via Serial connection in Tera Term as necessary. In the New Connection window, select the Serial radio button and the appropriate communications port for your PC (i.e., COM1).

b. From the File menu, choose Log…, and save the teraterm.log file to the Desktop. Ensure that the Append and Plain text check boxes are enabled (checked).

c. The Tera Term log file will create a record of every command issued and every output displayed.

Note: You can use this feature to capture the output from several commands in sequence and use it for network documentation purposes. For example, you could issue the show version, show ip interface brief, and show running-config commands to capture information about the router.

Step 2: Display the router running-configuration.

a. Use the console password to log in to the router.

b. Enter privileged EXEC mode.

c. From privileged EXEC mode enter the show running-config command.

d. Continue pressing the space bar when –More– is displayed until you see the router R1# prompt return.

e. From the File menu, choose Show Log Dialog. Click Close to end the log session.

Note: You can also copy and paste the text from the Tera Term window directly into a text editor.

Part 3: Use a Backup Configuration File to Restore a Router and Switch Configuration

Step 1: Erase the router startup-configuration and reload it.

a. From privileged EXEC mode erase the startup configuration.

R1# erase startup-config
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: complete

b. Reload the router.

R1# reload
Proceed with reload? [confirm]

c. At the System Configuration Dialog prompt, type no; a router prompt displays, indicating an unconfigured router.

               --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]:

Press RETURN to get started!
<output omitted>
Router>

d. Enter privileged EXEC mode and enter a show running-config command to verify that all of the previous configurations were erased.

Step 2: Edit the saved configuration backup file to prepare it for restoring the router configuration.

To restore the router configuration from a saved running configuration backup file, you must edit the text.

a. Open the teraterm.log text file.

b. Remove each instance of –More– in the text file.

Note: The –More– was generated by pressing the Spacebar when displaying the running configuration.

c. Delete the initial lines of the backup configuration file, so that the first line starts with the first configuration command as shown below.

service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption

d. In the lines for interface GigabitEthernet0/0/1, insert a new line to enable the interface.

interface GigabitEthernet0/0/1
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto

Change to:

interface GigabitEthernet0/0/1
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
 no shutdown

e. After you have made all of the edits to the backup configuration file, save your changes to filename R1-config-backup.

Note: When saving the file, an extension such as .txt, may be added to the filename automatically.

Step 3: Restore the router configuration.

You can restore the edited running configuration directly to the console terminal in router global configuration mode, and the configurations are entered as if they were commands entered individually at the command prompt.

a. From the Tera Term console connection to the router, enter global configuration mode.

b. From the File menu, select Send file….

c. Locate R1-config-backup and select Open.

d. Save the running configuration to the startup configuration file.

R1# copy running-config startup-config

e. Verify the new running configuration.

Step 4: Backup and restore the switch.

Go back to the beginning of Part 2 and follow the same steps to backup and restore the switch configuration.

Reflection Question

Why do you think it is important to use a text editor instead of a word processor to copy and save your command configurations?

A word processor could possibly add special control characters to the text making it difficult to use to restore the router.

Router Interface Summary Table

Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
4221 Gigabit Ethernet 0/0/0 (G0/0/0) Gigabit Ethernet 0/0/1 (G0/0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
4300 Gigabit Ethernet 0/0/0 (G0/0/0) Gigabit Ethernet 0/0/1 (G0/0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)

Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

Device Configs – Final

Router R1

R1# show run
Building configuration...


Current configuration : 3526 bytes
!
version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$AlSP$Zda/RxQljndxA/3et.RpC1
!
no aaa new-model
!
no ip domain lookup
!
login on-success log
!
subscriber templating
!
multilink bundle-name authenticated
!
crypto pki trustpoint TP-self-signed-3903873913
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3903873913
 revocation-check none
 rsakeypair TP-self-signed-3903873913
!
crypto pki certificate chain TP-self-signed-3903873913
 certificate self-signed 01
!
spanning-tree extend system-id
!
redundancy
 mode none
!
interface GigabitEthernet0/0/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet0/0/1
 ip address 192.168.1.1 255.255.255.0
 negotiation auto
!
interface Serial0/1/0
 no ip address
 shutdown
!
interface Serial0/1/1
 no ip address
 shutdown
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
control-plane
!
banner motd ^C Authorized Users Only! ^C
!
line con 0
 password 7 094F471A1A0A
 login
 transport input none
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 password 7 05080F1C2243
 login
!
end

Switch S1

S1# show run
Building configuration...

Current configuration : 1761 bytes
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname S1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$yo69$..aqaAWxTsB6FqL6mGQ1S1
!
no aaa new-model
system mtu routing 1500
!
!
no ip domain-lookup
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface FastEthernet0/1
 shutdown
!
interface FastEthernet0/2
 shutdown
!
interface FastEthernet0/3
 shutdown
!
interface FastEthernet0/4
 shutdown
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
 shutdown
!
interface FastEthernet0/8
 shutdown
!
interface FastEthernet0/9
 shutdown
!
interface FastEthernet0/10
 shutdown
!
interface FastEthernet0/11
 shutdown
!
interface FastEthernet0/12
 shutdown
!
interface FastEthernet0/13
 shutdown
!
interface FastEthernet0/14
 shutdown
!
interface FastEthernet0/15
 shutdown
!
interface FastEthernet0/16
 shutdown
!
interface FastEthernet0/17
 shutdown
!
interface FastEthernet0/18
 shutdown
!
interface FastEthernet0/19
 shutdown
!
interface FastEthernet0/20
 shutdown
!
interface FastEthernet0/21
 shutdown
!
interface FastEthernet0/22
 shutdown
!
interface FastEthernet0/23
 shutdown
!
interface FastEthernet0/24
 shutdown
!
interface GigabitEthernet0/1
 shutdown
!
interface GigabitEthernet0/2
 shutdown
!
interface Vlan1
 ip address 192.168.1.11 255.255.255.0
!
ip default-gateway 192.168.1.1
ip http server
ip http secure-server
!
banner motd ^C Authorized Users Only! ^C
!
line con 0
 password 7 13061E010803
 login
line vty 0 4
 password 7 13061E010803
 login
line vty 5 15
 login
!
end

Download PDF & PKT file Completed 100% Score:

[sociallocker id=”54558″][wpdm_package id=’Uploading…’][/sociallocker]

Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments